home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / sys-fs / captive-1.1.7-r1 / captive-1.1.7-r1.ebuild < prev    next >
Text File  |  2006-05-01  |  2KB  |  87 lines

  1. # Copyright 1999-2006 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/sys-fs/captive/captive-1.1.7-r1.ebuild,v 1.3 2006/04/05 12:46:06 genstef Exp $
  4.  
  5. inherit eutils
  6.  
  7. DESCRIPTION="Captive uses binary Windows drivers for full NTFS r/w access."
  8. HOMEPAGE="http://www.jankratochvil.net/project/captive/"
  9. SRC_URI="http://www.jankratochvil.net/project/captive/dist/${P}.tar.gz"
  10.  
  11. LICENSE="GPL-2"
  12. SLOT="0"
  13. KEYWORDS="~x86 -*"
  14.  
  15. IUSE="debug gtk readline"
  16.  
  17. RDEPEND="sys-libs/zlib
  18.     >=sys-fs/fuse-2.4
  19.     readline? ( sys-libs/readline )
  20.     >=dev-libs/openssl-0.9.7c
  21.     >=dev-libs/libxml2-2.4.29
  22.     >=gnome-base/orbit-2.8.2
  23.     gnome-base/gconf
  24.     gnome-base/libbonobo
  25.     gnome-base/gnome-vfs
  26.     dev-libs/popt
  27.     dev-libs/glib
  28.     gtk? (
  29.         dev-libs/atk
  30.         sys-fs/ntfsprogs
  31.         gnome-base/libbonoboui
  32.         gnome-base/libgnomeui
  33.         media-libs/libpng
  34.         >x11-libs/gtk+-2.2
  35.         x11-libs/pango
  36.     )"
  37.  
  38. DEPEND="${RDEPEND}"
  39.  
  40. pkg_setup() {
  41.     einfo "Adding captive user and group"
  42.     enewgroup captive || die "enewgroup captive failed"
  43.     enewuser captive -1 -1 /dev/null captive || die "enewuser captive failed"
  44. }
  45.  
  46. src_compile() {
  47.     # disable some tests to save time ;)
  48.     econf $(use_enable debug bug-replay) \
  49.         $(use_with readline) \
  50.         $(use_enable gtk install-pkg) \
  51.         --enable-fuse \
  52.         --disable-glibtest --disable-orbittest \
  53.         --with-tmpdir=/tmp --localstatedir=/var || die "econf failed"
  54.     emake || die "emake failed"
  55. }
  56.  
  57. src_install() {
  58.     make DESTDIR="${D}" install || die "make install failed"
  59.  
  60.     dodir   /var/lib/captive
  61.     diropts -m1777
  62.     dodir   /var/lib/captive/tmp
  63.     keepdir /var/lib/captive/tmp
  64.  
  65.     rm -R    ${D}/etc/rc.d
  66.  
  67.     dodoc AUTHORS ChangeLog README TODO
  68. }
  69.  
  70. pkg_postinst() {
  71.     einfo "Use /usr/sbin/captive-install-acquire to search for and"
  72.     einfo "install the needed drivers for captive NTFS."
  73.     ewarn "captive-install-acquire is only provided with USE=gtk"
  74.     einfo ""
  75.     einfo "Please use \"mount -t captive-ntfs /dev/hda1 /mnt/ntfs\" to mount ntfs partitions."
  76. }
  77.  
  78. pkg_postrm() {
  79.     #einfo Removing captive user
  80.     #userdel captive
  81.     #einfo Removing captive group
  82.     #groupdel captive
  83.     einfo ""
  84.     einfo "You will have to remove captive user and group manually"
  85.     einfo ""
  86. }
  87.